Home > CCNA EIGRP Lab

CCNA EIGRP Lab

January 25th, 2014 Go to comments

Question

Your company has just added R3 router to the existing network. But currently no routing updates are being exchanged between R3 and the network. All other connectivity, including Internet access are working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.

All passwords on all routers are set to cisco.

IP addresses are listed in the chart below.

ccna_eigrp_sim

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13
R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14
R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81
R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation

(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://juquitiba.sp.gov.br/?exams=eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://juquitiba.sp.gov.br/?exams=download/9tut.com_CCNA_EIGRP_sim_question.zip)

We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command

ccna_eigrp_sim_show_run

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router R3 with the following commands:

R3>enable (you have to enter Secret@9tut as its password here)

R3#configure terminal

R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

Check R1 router with the show running-config command:

ccna_eigrp_sim_show_run_2

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

R1#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router R3 to other routers!

Modifications:

Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:

R1:

!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0” on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.

(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:

!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!

If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.

Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:

router eigrp 212
network 192.168.77.0 0.0.0.3

The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.

You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15” under EIGRP process.

Comments
Comment pages
1 80 81 82 29
  1. Raju
    January 10th, 2018

    Hi Team,

    kindly provide me the latest dump for CCNA on raj09028 at gmail dot com

  2. Sandeep Singh
    January 17th, 2018

    Take a look on Quick Facts on EIGRP
    http://www.routexp.com/2017/11/quick-facts-on-eigrp.html

  3. Raju
    February 27th, 2018

    Hi guys any latest dumps for 200-125

    my exam is in next month.

    this is my email id :- raj09028 at gmail dot com

    thank you

  4. SHEROD57
    April 29th, 2018

    Hi Can someone please provide me the latest dumps for the
    ICND1 100-105.
    My email adrress is
    sheryler at comcast.net
    Thank you so much :) :) :)

  5. foomaqnshe
    May 4th, 2018

    thank u so much

  6. quantisol
    May 10th, 2018

    Thanks for the explanations.. God bless you. My exam is next week.

  7. Anonymous
    May 19th, 2018

    quantisol4atgmail.com am writing next week help me with the sim questions and others. Thanks CCNA guru’s

  8. Luis
    June 2nd, 2018

    This one I didn’t had in my exam today and I study alot

  9. William
    July 8th, 2018

    Do I need apply
    ip default-network 198.0.18.0
    ip route 0.0.0.0 0.0.0.0 198.0.18.5
    if R1 is missing?

  10. Atul Verma
    July 17th, 2018

    If you are looking for the comparison of the commands between Cisco and other, here are the links
    Cisco and Brocade
    http://www.routexp.com/2017/06/cli-commands-comparison-cisco-vs-brocade.html

    Cisco and Juniper
    http://www.routexp.com/2017/05/cisco-ios-commands-vs-juniper-junos.html

  11. FELP
    July 20th, 2018

    Alguem poderia me enviar dumps atualizados do ccna “fjorge28” gmail

  12. Yousif
    August 31st, 2018

    Hello, Can someone provide me with the latest CCNA dumps please E mail >
    Mohammedmoneer1988 {at} yahoo {dot} com
    Thanks!

  13. Erik
    September 2nd, 2018

    Thank you so much for the explanation at the “Note” part

  14. ccna-pursuit
    September 18th, 2018

    are there any chances that this lab will be in exam or Is it for practice purpose

  15. Erik
    September 28th, 2018

    @ccna-pursuit
    I think it’s only for practise purpose.

  16. cleo
    October 11th, 2018

    may i know the password, not working Secret@9tut. Thanks

  17. Tatsev
    October 18th, 2018

    Hi Guys,
    please send my the last guides ccna 200 125 to useradmin@dotmaildotbg

    thanks a lot !

  18. wonderkid
    October 31st, 2018

    I wonder has there been a new dump recently? anyone have a link?

  19. wonderkid
    November 14th, 2018

    why are we not adding no auto summary to R1 but we added it to R3?

Comment pages
1 80 81 82 29
Add a Comment