Home > CCNA EIGRP Lab

CCNA EIGRP Lab

January 25th, 2014 Go to comments

Question

Your company has just added R3 router to the existing network. But currently no routing updates are being exchanged between R3 and the network. All other connectivity, including Internet access are working properly.

The task is to identify the fault(s) and correct the router configuration to provide full connectivity between the routers.

All passwords on all routers are set to cisco.

IP addresses are listed in the chart below.

ccna_eigrp_sim

R1
Fa0/0: 192.168.77.33
S1/0: 198.0.18.6
S0/1: 192.168.60.25
S0/0: 192.168.36.13
R2
Fa0/0: 192.168.60.97
Fa0/1: 192.168.60.113
S0/0: 192.168.36.14
R3
Fa0/0: 192.168.77.34
Fa0/1: 192.168.60.65
Fa1/0: 192.168.60.81
R4
Fa0/0: 192.168.60.129
Fa0/1: 192.168.60.145
S0/1: 192.168.60.26

Answer and explanation

(Note: If you are not sure how EIGRP works, please read my EIGRP tutorial: http://juquitiba.sp.gov.br/?exams=eigrp-routing-protocol-tutorial. Note: You can download this sim to practice here: http://juquitiba.sp.gov.br/?exams=download/9tut.com_CCNA_EIGRP_sim_question.zip)

We should check the configuration of the new added router first because it does not function properly while others work well. From the command line interface of R3 router, enter the show running-config command

ccna_eigrp_sim_show_run

From the output above, we know that this router was wrongly configured with an autonomous number (AS) of 22. When the AS numbers among routers are mismatched, no adjacency is formed.

(You should check the AS numbers on other routers for sure)

To solve this problem, we simply re-configure router R3 with the following commands:

R3>enable (you have to enter Secret@9tut as its password here)

R3#configure terminal

R3(config)#no router eigrp 22

R3(config)#router eigrp 212

R3(config-router)#network 192.168.60.0

R3(config-router)#network 192.168.77.0

R3(config-router)#no auto-summary

R3(config-router)#end

R3#copy running-config startup-config

Check R1 router with the show running-config command:

ccna_eigrp_sim_show_run_2

Notice that it is missing a definition to the network R3. Therefore we have to add it so that it can recognize R3 router

R1>enable (you have to enter cisco as its password here)

R1#configure terminal

R1(config)#router eigrp 212

R1(config-router)#network 192.168.77.0

R1(config-router)#end

R1#copy running-config startup-config

Now the whole network will work well. You should check again with ping command from router R3 to other routers!

Modifications:

Maybe in this EIGRP Sim you will see the “passive-interface …” command somewhere in R1 configuration. If the link between R1 to R2; or R1 to R3; or R1 to R4) routers has the “passive interface” then we have to remove it with the “no passive-interface …” command because it prevents EIGRP update from being sent on that interface. But if the “passive interface” is applied to the link between R1 and ISP router like this:

R1:

!
router eigrp 212
passive-interface s1/0
!

then we just leave it. Don’t use the “no passive-interface s1/0” on R1 because the link between R1 & ISP doesn’t need EIGRP to run on it. A static route from R1 to ISP & “ip default-network” command in R1 are correct so that all the routers (R1, R2, R3, R4) can access the Internet.

(Note: The “ip default-network” command in R1 will advertise the static route of R1 (to go to the Internet) to other routers (R2,R3,R4) so that they can access the Internet too). In the exam you will see these lines in R1 configuration:

!
ip default-network 198.0.18.0
ip route 0.0.0.0 0.0.0.0 198.0.18.5
!

If you want to learn more about “ip default-network” command please read: http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a0080094374.shtml

I read recent comments and realized that you will see the “passive-interface” in the link between R1 & ISP router so just leave it.

Note: Also some readers confuse about if we should use the wildcard masks on the “network” statements under EIGRP process or not. For example should we use:

router eigrp 212
network 192.168.77.0 0.0.0.3

The answer is: we can use wildcard masks or not, it does not matter. Not having a wildcard mask does not make the routes conflicting. The “network …” command in EIGRP (and OSPF, RIP) does not means “advertise this network” but means “If I has interface(s) belongs to this network please turn on EIGRP on that interface. Therefore when you don’t use wildcard mask EIGRP will turn on EIGRP on all interfaces that belongs to the network you specify in the “network …” command.

You should only use wildcard mask on EIGRP if you have 2 or more interfaces that belong to the same major networks but you don’t want to run EIGRP on all of them. For example if your router has 2 interfaces whose IP addresses are 192.168.30.1/28 and 192.168.30.17/28 but you only want to run EIGRP on the first interface, you can type “network 192.168.30.0 0.0.0.15” under EIGRP process.

Comments
Comment pages
1 79 80 81 82 29
  1. Ted
    August 15th, 2016

    anyone

    someone in the ‘ Share your CCNA Experience ‘ is disagreeing with me regarding line 3
    in the acl2 exam being ‘ permit ip any any ‘

    for the mod 1 and 2 the 9tut shows to use permit ip any any
    for mods 3,4 it says:

    access-list 100 permit ip any host
    (The IP of Public Web Server will surely be given in this question) but in the exam you should use “access-list 100 permit ip any any”

    any thoughts, recommendations ?
    as I have seen many comment to use ‘ any any’ I had thought that sounded like ‘ cisco’s ‘ answer..

  2. HP
    August 15th, 2016

    permit ip any any is the correct one.

  3. ted
    August 16th, 2016

    Hello,
    Has anyone had in the EIGRP troubleshooting sim in the exam any of these answers:

    loopback interface shut down
    Passive-interface is configured.
    auto-summary enabled so only the 10.0.0.0 network is shown. (I ask this question as the packet tracer sim I have shows R4 in incorrect AS
    and auto-summary enabled)

    for OSPF anyone get this an answer:
    The Layer 2 encapsulation of the serial links is mismatched

    Thanks

  4. Ted
    August 16th, 2016

    Hello,
    Has anyone had in the EIGRP troubleshooting sim in the exam any of these answers
    I know its not likely the answers for the eigrp troubleshooting sim or eigrp would be these answers, just wanted to be sure, especially if auto summary is enabled:

    1. The loopback interface on RX is shut down.( RX being for different question)
    2. Passive-interface is configured.
    3 . By default, automatic summarization is enabled, so only the 10.0.0.0 network is shown.
    (I ask this question as the packet tracer sim I have shows R4 in incorrect AS
    and auto-summary enabled)

    Although EIGRP sim says no auto summary is default in the exam so I am guessing this is correct answer.
    Note: In the exam, this sim uses IOS version 15 so “no auto-summary” is the default setting of EIGRP. You don’t have to type it.

    for OSPF anyone get this an answer:
    The Layer 2 encapsulation of the serial links is mismatched

    Thanks

  5. Fer
    August 17th, 2016

    Is this labs are on the test?

  6. Light
    August 18th, 2016

    @Ted, it could be these answers or the old ones or a mix. 9tut explains how to look for BOTH

    just read the explanations on 9tut about the answers and how to look for the alternative possibilities

  7. RT
    August 18th, 2016

    Hi everyone, i need help for confusion regarding labs:
    i am a bit confused about labs to be appear in exam and and what i got is below.
    there will be 4 labs consist of acl1, acl2, eigrp and ospf
    Acl1 (no need to configure just use show commands to answer multiple choice questions)
    Acl2 need configurations
    EIGRP: (CONFUSED: EITHER WE NEED TO CONFIGURE IT AS REQUIRED OR WE HAVE TO TROUBLESHOOT IT OR JUST USE SHOW COMMANDS TO ANSWER MULTIPLE CHOICE QUESTIONS)
    OSPF: (CONFUSED: EITHER WE NEED TO CONFIGURE IT AS REQUIRED OR WE HAVE TO TROUBLESHOOT IT OR JUST USE SHOW COMMANDS TO ANSWER MULTIPLE CHOICE QUESTIONS)
    Please help me in this regard and correct me if am wrong.
    Thanks in avance

  8. Anonymous
    August 19th, 2016

    can someone send me questions dump in watson Im taking ccna today, karbug14athotmail.com

  9. soso
    August 19th, 2016

    Hi All ,can anyone send me the VCE setup sopprusbarbosa at gmail dot com

  10. Krutz
    August 25th, 2016

    Hello, Everyone. Is there any chance that I can have new CCNA exams dumbs and lab since I have old one. So i would like to update my self. loselife44 on yahoocom

  11. jhoncas
    September 6th, 2016

    Hello everyone, can someone send me the last question dump CCNA Exam 200-125
    {email not allowed}

  12. jhoncas
    September 6th, 2016

    Hello everyone, can someone send me the last question dump CCNA Exam 200-125 {email not allowed}

  13. jhoncas
    September 6th, 2016

    trespuntosnegros gmail.com

  14. Bob
    September 6th, 2016

    In the question here only IP address is given without prifix/subnet mask so how to evaluate the subnet mask ?

  15. Manjunath
    September 11th, 2016

    Hi All,

    looking at all positive responses
    I will take ccna exam this month end
    Please share the latest dumps or the spike dumps to {email not allowed}
    Thank you all in advance.

    Best Regards,
    Manjunath

  16. Manjunath
    September 11th, 2016

    Hi All,

    looking at all positive responses
    I will take ccna exam this month end
    Please share the latest dumps or the spike dumps to
    princemanjunath22 at rate gmail.com
    Thank you all in advance.

    Best Regards,
    Manjunath

  17. kk
    October 10th, 2016

    Hi,

    Can anyone explain why the network advertised is ‘network 192.168.77.0’ instead of ‘network 192.168.77.32 0.0.0.3’ ?

    Thanks

  18. Ahmad
    October 11th, 2016

    Dear kk
    You can use wildcard masks or not, it does not matter.
    depending on the question, wildcard like 0.0.0.3 use for specify network with range 3 ip
    you can search about wildcard article :)

  19. awi-hensem
    November 28th, 2016

    just pass today – 3 hours ago..

    171q still valid – thanks to PAPP, lab question ACL Mod3, tshoot ospf, eigro, dhcp.. Thanks to 9tut. New question, but forget already. Involving acl.

  20. RusKZ
    January 4th, 2017

    How does the test tshoot ospf?

  21. Myra
    January 10th, 2017

    (trance, progressive) armin van buuren anthems fhg_mp3 320kbps – myfreemp3.review/search/(trance,-progressive)-armin-van-buuren—anthems—fhg_mp3—320kbps/
    download free music

  22. Anonymous
    January 11th, 2017

    plz is 171 q is vaild untill now ??

  23. FreshSent
    February 21st, 2017

    Yes, 171 q is still helpful, there is a 182q now, but 171 is still good. Good luck

  24. BIGBEAR
    April 26th, 2017

    Hello everyone, can someone send me the last question dump CCNA Exam 200-125
    I will take ccna exam next month
    rngeanmongkoln at gmail.com

    Best Regards,

  25. PIHU
    April 27th, 2017

    can ny1 help me with ccna 200-125 latest dumps. i will take exam next month
    pihuccna at gmail dot com

  26. meryem
    May 4th, 2017

    Where are the questions ??

  27. mohan
    May 5th, 2017

    Hello everyone, can someone send me the last question dump CCNA Exam 200-125
    I will take ccna exam next month
    gcmohan81 at yahoo.com

    thanks

  28. New questions
    May 25th, 2017

    For dumps join the “share your v3.0 experience” forum

  29. CCNA 200-125
    May 25th, 2017

    I am taking the exam tomorrow !!!!!!!!!!!!!!

  30. Eric
    July 6th, 2017

    Nice lab;) For Cisco and other vendors, here is a command line referance!!
    http://ipcisco.com/comparison-of-top-four-vendorss-command-line/

  31. Slim
    July 11th, 2017

    Hi evrybody,
    Could you please share with me the latest valid dump on this address: basly.mohamed.slim(@)gmail(dot)com.
    i’m passing the exam on the 25th of this month. i really need your help.
    Thanks and regards.

  32. Ana
    July 18th, 2017

    where is the question?? can someone help me???

  33. rol
    September 20th, 2017

    im taking ccna exam by next next week please send me lates dumps {email not allowed}

  34. ThioSan
    October 31st, 2017

    The approved Chinese eviction is valid. I spent yesterday

  35. dhd
    November 7th, 2017

    Why eigrp config was

    R3(config-router)#network 192.168.60.0
    R3(config-router)#network 192.168.77.0

    based on the info network was not /24

  36. AC-23
    November 22nd, 2017

    @dhd
    I think because 192.168.77.0/30 is the zero subnet
    then come:
    192.168.77.4/30
    192.168.77.8/30
    .
    .
    .

  37. AC-23
    November 22nd, 2017

    or maybe summarized as a class C networks

  38. manjunath
    November 27th, 2017

    interface Serial0/1
    ip address 192.168.60.26 255.255.255.252

    in router 4 network id is 192.168.60.25. why adding network 192.168.60.0 ?

  39. Cory
    December 6th, 2017

    Wendell, what labs did you get? Thanks

  40. Cory
    December 6th, 2017

    Also, is that the chinese dump?

  41. Sandeep Singh
    December 19th, 2017

    If you are looking for the comparison of the commands between Cisco and other, here are the links
    Cisco and Brocade
    http://www.ttlbits.com/2017/06/cli-commands-comparison-cisco-vs-brocade.html

    Cisco and Juniper
    http://www.ttlbits.com/2017/05/cisco-ios-commands-vs-juniper-junos.html

  42. Hello Guys
    January 1st, 2018

    Hello Guys Question

    On R3

    R3
    Fa0/0: 192.168.77.34
    Fa0/1: 192.168.60.65
    Fa1/0: 192.168.60.81

    On Fa0/1 and Fa1/0 we have same network why wild card is not required can some one explain please ?

  43. Hello Guys
    January 1st, 2018

    I think it need wild card mask as how will the router1 advertise to networks you can see on the
    192.168.60.65 /255.255.255.240 (/28)
    192.168.60.81/255.255.255.240(/28)
    Means subnet its changeable by 16 !
    so its 192.168.60.0 first subnet
    .16
    .32
    .48
    .64

    network 192.168.60.64 0.0.0.0.15

    So you will need to put wild card mask as if not how will R1 make difference from the routes on R4 and R2 they have also subnets in 192.168.60.x networks as well ,please elaborate on this

  44. Asad
    January 1st, 2018

    I will give the ccna exam on Friday 12th, 2018. can anyone give me the latest dump? my email address: {email not allowed}

  45. Anonymous
    January 1st, 2018

    please give me the latest dump sent me gmail address mdaasad89@

  46. NovoMG
    January 4th, 2018

    In R3 example, EIGRP will be activated on both 192.168.60.x interfaces, both of them are covered by Private Classful class C IP Address 192.168.60.0/24:

    ——————

    The EIGRP network commands allows two syntax options: one with a wildcard mask at the end and
    one without.
    With no wildcard mask listed, this command must list a classful network (a Class A, B, or C network number). Once configured, this command tells the router to do the following:
    • Look for that router’s own interfaces with addresses in that classful network
    • Enable EIGRP on those interfaces
    Once enabled, EIGRP starts advertising about the subnet connected to an interface. It also starts
    sending hello messages and listening for incoming hello messages, trying to form neighbor
    relationships with other EIGRP routers.

    Note: Interestingly, on real routers, you can type an EIGRP network number command and
    use a dotted-decimal number that is not a classful network number; in that case, IOS
    does not issue an error message. However, IOS changes the number you typed to be the
    classful network number in which that number resides. For example, IOS changes the
    network 10.1.1.1 command to network 10.0.0.0.

    The EIGRP network command syntax without the wildcard mask, may be exactly what an engineer wants to use, but it also might prove a bit clumsy. For instance, if an engineer wants to enable EIGRP on G0/0, and not on G0/1, and they both have IP addresses in Class A network 10.0.0.0, the network 10.0.0.0 EIGRP subcommand would match both interfaces, instead of just G0/0.

    IOS has a second option for the EIGRP network command that uses a wildcard mask so that the engineer can match exactly the correct interface IP addresses intended. In this case, the network command does not have to list a classful network number. Instead, IOS matches an interface IP address that would be matched if the address and wildcard mask in the network command were part of an access control list (ACL). The logic works just like an ACL address and wildcard mask and just like the address/mask logic in the OSPF network commands.
    ———————–
    Source: Odom W. – Cisco CCNA Routing and Switching ICND2 200-101 Official Cert Guide – 2013.pdf (page 321)
    ————————-

  47. Datta
    January 9th, 2018

    Hi guys, please provide me latest dump CCNA on dattaprasadpisal at gmail dot com

  48. Raju
    January 10th, 2018

    Hi Team,

    kindly provide me the latest dump for CCNA on raj09028 at gmail dot com

  49. Sandeep Singh
    January 17th, 2018

    Take a look on Quick Facts on EIGRP
    http://www.routexp.com/2017/11/quick-facts-on-eigrp.html

Comment pages
1 79 80 81 82 29
Add a Comment