Home > EIGRP Questions

EIGRP Questions

November 3rd, 2017 Go to comments

Note: If you are not sure about EIGRP, please read our EIGRP Tutorial.

Question 1

Explanation

Below is an example of the “show ip eigrp neighbors” output.

EIGRP_show_ip_eigrp_neighbors_2.jpg

Let’s analyze these columns:

+ H: lists the neighbors in the order this router was learned
+ Address: the IP address of the neighbors
+ Interface: the interface of the local router on which this Hello packet was received
+ Hold (sec): the amount of time left before neighbor is considered in “down” status
+ Uptime: amount of time since the adjacency was established
+ SRTT (Smooth Round Trip Timer): the average time in milliseconds between the transmission of a packet to a neighbor and the receipt of an acknowledgement.
+ RTO (Retransmission Timeout): if a multicast has failed, then a unicast is sent to that particular router, the RTO is the time in milliseconds that the router waits for an acknowledgement of that unicast.
+ Queue count (Q Cnt): shows the number of queued EIGRP packets. It is usually 0.
+ Sequence Number (Seq Num): the sequence number of the last update EIGRP packet received. Each update message is given a sequence number, and the received ACK should have the same sequence number. The next update message to that neighbor will use Seq Num + 1.

In this question we have to check the RTO and Q cnt fields.

Question 2

Explanation

To configure EIGRP for IPv6 we must explicitly specify a router ID before it can start running. For example:

ipv6 router eigrp 1
eigrp router-id 2.2.2.2
no shutdown

Notice that EIGRP for IPv6 router-id must be an IPv4 address. EIGRP for IPv4 can automatically pick-up an IPv4 to use as its EIGRP router-id with this rule:
+ The highest IP address assigned to a loopback interface is selected as the router ID.
+ If there are not any loopback addresses configured, the highest IP address assigned to any other active interface is chosen as the router ID

EIGRPv3 also uses the AS number (for example: ipv6 eigrp 1 under interface mode).

Question 3

Explanation

The “show ipv6 eigrp neighbors” command displays the neighbors discovered by the EIGRPv6. Notice that the neighbors are displayed by their link-local addresses.

show_ipv6_eigrp_neighbors.jpg

Question 4

Explanation

The goodbye message is a feature designed to improve EIGRP network convergence. The goodbye message is broadcast when an EIGRP routing process is shutdown to inform adjacent peers about the impending topology change. This feature allows supporting EIGRP peers to synchronize and recalculate neighbor relationships more efficiently than would occur if the peers discovered the topology change after the hold timer expired.

The following message is displayed by routers that run a supported release when a goodbye message is received:

*Apr 26 13:48:42.523: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.1.1.1 (Ethernet0/0) is down: Interface Goodbye received

Reference: http://www.cisco.com/c/en/us/td/docs/ios/12_2/ip/configuration/guide/fipr_c/1cfeigrp.html

Note: In this question we should understand “impending”, not “implementing” as there are no correct answers with “implementing” topology change.

Question 5

Explanation

With auto-summary feature is turned on, EIGRP will summary these networks to their classful networks automatically. For example:
+ 172.15.4.0 belongs to class B so it will be summarized to 172.15.0.0
+ 10.4.3.0 belongs to class A so it will be summarized to 10.0.0.0
+ 192.168.4.0 belongs to class C so it will be summarized to 192.168.4.0 (same)

Question 6

Explanation

Split horizon is used in distance vector routing protocols (like RIP, EIGRP) to prevent routing loops by prohibiting a router from advertising a route back to the interface from which it was learned.

Question 7

Explanation

EIGRP provides a mechanism to load balance over unequal cost paths (or called unequal cost load balancing) through the “variance” command. In other words, EIGRP will install all paths with metric < variance * best_metric into the local routing table, provided that it meets the feasibility condition (to prevent routing loop). The feasibility condition states that, the Advertised Distance (AD) of a route must be lower than the feasible distance of the current successor route.

Question 8

Explanation

EIGRP provides a mechanism to load balance over unequal cost paths (or called unequal cost load balancing) through the “variance” command. In other words, EIGRP will install all paths with metric < variance * best_metric into the local routing table, provided that it meets the feasibility condition (to prevent routing loop). The feasibility condition states that, the Advertised Distance (AD) of a route must be lower than the feasible distance of the current successor route.

Question 9

Explanation

From the routing table we learn that network 192.168.10.0/30 is learned via 2 equal-cost paths (192.168.10.9 &192.168.10.5) -> traffic to this network will be load-balancing.

Question 10

Explanation

This is an example of how to configure EIGRP for IPv6:

interface Serial0/0
no ip address
ipv6 address FE80::1 link-local
ipv6 address 2010:AB8::1/64
ipv6 enable
ipv6 eigrp 1
!
ipv6 router eigrp 1
eigrp router-id 2.2.2.2
no shutdown

As you can see, EIGRP for IPv6 can only be enabled under each interface -> A is correct.

Under EIGRP process there is a shutdown feature where you can turn on or off -> E is correct.

Question 11

Explanation

These networks will be summarized to the major networks of that class so:
+ 10.4.3.0 belongs to class A -> It will be summarized into 10.0.0.0
+ 172.16.4.0 belongs to class B -> It will be summarized into 172.16.0.0
+ 192.168.2.0 belongs to class C -> It will be summarized into 192.168.2.0 (not changed)

Question 12

Comments (30) Comments
  1. Tepi
    February 8th, 2017

    I think Q4 should read EIGRP goodbye messages give notice of “impending” topology changes.

  2. shahanga
    February 16th, 2017

    i just see the answers(explanation), where are questions?

  3. ccna
    February 21st, 2017

    where are the questions..??? I am a premium account holder and still cant view information

  4. kristventu
    February 28th, 2017

    check CCNA FAQs & Tips for all Questions

  5. Konzen
    March 3rd, 2017

    pls navigate this page and you will see where they are. this is already spoon feeding guys don’t make a fool of yourself

  6. wassa
    June 15th, 2017

    question 11

    If R1 is configured as shown, which three addresses will be received by other routers that are running EIGRP on the network? (Choose three)
    R1(config)#router eigrp 103
    R1(config-router)#network 10.4.3.0
    R1(config-router)#network 172.16.4.0
    R1(config-router)#network 192.168.2.0
    R1(config-router)#auto-summary
    A. 172.16.4.0
    B. 10.0.0.0
    C. 172.16.0.0
    D. 192.168.2.0
    E. 192.168.0.0
    F. 10.4.3.0

    Answer: B C D

    Explanation

    These networks will be summarized to the major networks of that class so:
    + 10.4.3.0 belongs to class A -> It will be summarized into 10.0.0.0
    + 172.16.4.0 belongs to class B -> It will be summarized into 172.16.0.0
    + 192.168.2.0 belongs to class C -> It will be summarized into 192.168.2.0 (not changed)

    but !!! class c is 192.168.0.0 isn’t it??

  7. Kiks
    June 20th, 2017

    @9tut, I don’t understand Q11??? and I agree with Wassa..can you explain???

  8. Becky
    June 26th, 2017

    Q2 – Shoulnt it be d

  9. OSC
    June 27th, 2017

    @wassa & @Kiks
    Clas C is a /24 then we use the entirely 24 bits 192.168.4.

  10. Ven
    July 7th, 2017

    @osc 👍

  11. Mr west
    July 9th, 2017

    hello I am taking my exam on Tuesdays…..what’s there to expect?

  12. Mr west
    July 9th, 2017

    CCNA

  13. Hmm
    July 9th, 2017

    @wassa , in the case of auto summary …
    class A is a /8 — this bit unchanged
    class B is a /16– this bit unchanged
    class C is a /24– this bit unchanged

  14. vrayo
    July 19th, 2017

    All the questions of the CCNA exam last version, can be found here?

  15. fihmi
    August 31st, 2017

    please guysss Q10 is wrong
    eigrp it’s globally configured not on interface

  16. Alsatian
    September 1st, 2017

    Please, i’m just seeing the explanations. I’ll like to know the questions are.

  17. Preeti
    September 21st, 2017

    Passed exam today.
    New Ques. Which codes appear in output of command ‘sh ip eigrp topology’? (choose 2)
    A. U-Update
    B. S-Static
    C. C-Connected
    D. A-Active
    E. I-inter-area
    Answer: A,D

  18. Mack
    October 6th, 2017

    Passed today with 8xx.
    Used this site and this dumps https://drive.google.com/open?id=0B5mAFqgydmCzUWJPTTFkemFuQTA

  19. ahmed kamal
    October 9th, 2017

    i want dumps new !

  20. anonnnnn
    October 23rd, 2017

    @mack plxx share new question which were appear in exam

  21. Peter.Thanh
    January 14th, 2018

    Can someone tell me where can i find the questions related to this explanation ?

  22. Hidelmar
    January 27th, 2018

    Q 10 is wrong….. answer shoul be B and E:

    (im and spanish speaker, but i think you will understand)

    Globally:

    ipv6 unicast-routing ; Habilita enrutamiento en el equipo

    ipv6 router eigrp ; Crea el sistema autónomo de EIGRP.

    router-id ; Asigna el identificador.

    no shutdown ; Habilita el proceso de EIGRP. Por defecto el proceso al crearse se encuentra deshabilitado.

    Interface

    IPv6 eigrp ; Habilita EIGRP en dicha interface.

    IPv6 enable ; Asigna una direccion IPv6 cuando no se cuenta con direccione IPv6. Crea una dirección IPv6 Link-local en combinación de IPv6 EUI-64 y la dirección MAC de la interface.

  23. raptor
    January 29th, 2018

    Q10 is correct Eigrpv6 is configured on interface

  24. cthelite
    February 23rd, 2018

    Hidelmar is absolutely correct. And so is Raptor. AND it also supports shutdown. Welcome to the craziness!

  25. max
    March 27th, 2018

    please send me the latest dumps
    max.sarmd (at ) gmail (dot) com

  26. gaurav4u
    May 3rd, 2018

    @hidelmar@cthelite Q10, I guess is correct, because here we are dealing with EIGRP IPv6 and not IPV4. EIGRP on IPv4 is configured in global configuration mode, but not on interface.
    EIGRP on IPv6 is also configured in global configuration mode but the difference here is that EIGRP IPv6 also requires to be set on an interface, whereas EIGRP IPv4 does not need any interface configuration.

  27. CCNAtut
    May 24th, 2018

    @9tut Q 10- please rectify-
    EIGRP is configured globally and enabled under an interface for IPv6

    below is the config-:

    R1(config)# ipv6 router eigrp 1 /* global comnfig of EIGRP in IPv6 */
    R1(config)# router-id 1.1.1.1
    R1(config)# no shut

    R1(config)# int g0/0
    R1(config-if)# ipv6 eigrp 1 /* enabling EIGRP in IPv6

    R1(config)# int g0/1
    R1(config-if)# ipv6 eigrp 1 /* enabling EIGRP in IPv6

    Option A is wrong as it says it is globally configured and not enabled under an interface.

    Option B and E are correct. Please change to the answers.

  28. 9tut
    May 24th, 2018

    @CCNAtut: Q.10 answer A means we cannot enable EIGRP IPv6 with the “network …” command under EIGRP process so it is correct.

  29. Muhammad bilal
    July 3rd, 2018

    how i do the lab of the questions i cannot understand :( that how i do it

  30. Meathman
    July 12th, 2018

    Hello 9tut,
    Question 5 above refers to the network addresses shown by the ‘ip route’ command after ‘auto-summary’. The three networks are summarised in accordance with Class A, Class B and Class C, with no change taking place for the 192.168.4.0 network.
    The same question appears in the EIGRP Test. A person is asked to pick three answers. I picked the three as displayed above. When I finished the test I got an incorrect mark for the question. The explanation was that no change would take place for the /24 network. That is true but in terms of the ip route command, the /24 network will appear, along with the /8 and /16. In fact the same layout appears in Q11 above and the three networks are displayed, which would be correct.
    The test-answer is wrong. Could it be rectified? It will cause confusion if not corrected.

Add a Comment